Wiki source code of Iscsi Debian 11
Version 3.1 by René Schmidt on 2023/09/25 13:17
Show last authors
| author | version | line-number | content |
|---|---|---|---|
| 1 | sudo apt install open-icsci | ||
| 2 | sudo apt install open-iscsi | ||
| 3 | sudo apt install iscsi-initiator-utils | ||
| 4 | sudo apt install iscsi-initiator-utils | ||
| 5 | |||
| 6 | apt install ntfs-3g | ||
| 7 | nano /etc/iscsi/iscsid.conf | ||
| 8 | |||
| 9 | |||
| 10 | |||
| 11 | |||
| 12 | dmesg | ||
| 13 | find / | grep 11.12.10.10/Amaflix4 | ||
| 14 | find / | grep -i 11.12.10.10/Amaflix4/Plex_Datenbank | ||
| 15 | sudo mount -o username=Amaflix4\admin,password=pw ~/~/11.12.10.131/Amaflix4/Plex_Datenbank /media/datengrab | ||
| 16 | apt install cifs-util | ||
| 17 | sudo apt install cifs-util | ||
| 18 | sudo apt install samba smbclient cifs-utils | ||
| 19 | |||
| 20 | |||
| 21 | |||
| 22 | |||
| 23 | |||
| 24 | |||
| 25 | sudo mount -t cifs -o username=admin,password=pw ~/~/11.12.10.131/Amaflix4/Plex_Datenbank /mnt/datengrab Pfad für das einbinden auf dem Server | ||
| 26 | |||
| 27 | |||
| 28 | icsiadm -m discovery -p 11.12.10.131 -t sendtargets | ||
| 29 | |||
| 30 | |||
| 31 | iscsiadm -m node -T iqn.1994-11.com.netgear:amaflix4:cc374a2e:sepsesam -p 11.12.10.131 ~-~-login Source | ||
| 32 | |||
| 33 | mount /dev/sdb /mnt/iscsi Target einbindung auf dem Server | ||
| 34 | |||
| 35 | |||
| 36 | = Filesystem Iscsi Error = | ||
| 37 | |||
| 38 | mount(2) system call failed: Die Struktur muss bereinigt werden. | ||
| 39 | |||
| 40 | ERROR: The filesystem has valuable metadata changes in a log which needs to be replayed. Mount the filesystem to replay the log, and unmount it before re-running **xfs_repair**. If you are unable to mount the filesystem, then use the -L option to destroy the log and attempt a repair. | ||
| 41 | |||
| 42 | sudo e2fsck -y /dev/sdb | ||
| 43 | |||
| 44 | |||
| 45 | |||
| 46 | |||
| 47 | |||
| 48 |