Wiki-Quellcode von Iscsi Debian 11 (Anbindung Storage )
Zuletzt geändert von René Schmidt am 2023/09/25 13:20
Verstecke letzte Bearbeiter
| author | version | line-number | content |
|---|---|---|---|
![]() |
4.1 | 1 | |
| 2 | |||
| 3 | = Vorbereitung des Servers = | ||
| 4 | |||
| 5 | (% class="box" %) | ||
| 6 | ((( | ||
![]() |
1.1 | 7 | sudo apt install open-icsci |
| 8 | sudo apt install open-iscsi | ||
| 9 | sudo apt install iscsi-initiator-utils | ||
| 10 | sudo apt install iscsi-initiator-utils | ||
![]() |
4.1 | 11 | ))) |
![]() |
1.1 | 12 | |
![]() |
4.1 | 13 | (% class="box" %) |
| 14 | ((( | ||
![]() |
1.1 | 15 | apt install ntfs-3g |
| 16 | nano /etc/iscsi/iscsid.conf | ||
![]() |
4.1 | 17 | ))) |
![]() |
1.1 | 18 | |
| 19 | |||
| 20 | |||
| 21 | |||
| 22 | dmesg | ||
| 23 | find / | grep 11.12.10.10/Amaflix4 | ||
| 24 | find / | grep -i 11.12.10.10/Amaflix4/Plex_Datenbank | ||
| 25 | sudo mount -o username=Amaflix4\admin,password=pw ~/~/11.12.10.131/Amaflix4/Plex_Datenbank /media/datengrab | ||
| 26 | apt install cifs-util | ||
| 27 | sudo apt install cifs-util | ||
| 28 | sudo apt install samba smbclient cifs-utils | ||
| 29 | |||
| 30 | |||
| 31 | |||
| 32 | |||
![]() |
4.1 | 33 | = Mounten der Laufwerke = |
![]() |
1.1 | 34 | |
| 35 | |||
![]() |
4.1 | 36 | (% class="box" %) |
| 37 | ((( | ||
![]() |
1.1 | 38 | sudo mount -t cifs -o username=admin,password=pw ~/~/11.12.10.131/Amaflix4/Plex_Datenbank /mnt/datengrab Pfad für das einbinden auf dem Server |
![]() |
4.1 | 39 | ))) |
![]() |
1.1 | 40 | |
![]() |
4.1 | 41 | (% class="box" %) |
| 42 | ((( | ||
![]() |
1.1 | 43 | icsiadm -m discovery -p 11.12.10.131 -t sendtargets |
![]() |
4.1 | 44 | ))) |
![]() |
1.1 | 45 | |
![]() |
4.1 | 46 | (% class="box" %) |
| 47 | ((( | ||
![]() |
1.1 | 48 | iscsiadm -m node -T iqn.1994-11.com.netgear:amaflix4:cc374a2e:sepsesam -p 11.12.10.131 ~-~-login Source |
![]() |
4.1 | 49 | ))) |
![]() |
1.1 | 50 | |
![]() |
4.1 | 51 | (% class="box" %) |
| 52 | ((( | ||
![]() |
1.1 | 53 | mount /dev/sdb /mnt/iscsi Target einbindung auf dem Server |
![]() |
4.1 | 54 | ))) |
![]() |
1.1 | 55 | |
| 56 | |||
![]() |
3.1 | 57 | = Filesystem Iscsi Error = |
![]() |
1.1 | 58 | |
![]() |
3.1 | 59 | mount(2) system call failed: Die Struktur muss bereinigt werden. |
| 60 | |||
| 61 | ERROR: The filesystem has valuable metadata changes in a log which needs to be replayed. Mount the filesystem to replay the log, and unmount it before re-running **xfs_repair**. If you are unable to mount the filesystem, then use the -L option to destroy the log and attempt a repair. | ||
| 62 | |||
![]() |
4.1 | 63 | (% class="box" %) |
| 64 | ((( | ||
![]() |
3.1 | 65 | sudo e2fsck -y /dev/sdb |
![]() |
4.1 | 66 | ))) |
![]() |
3.1 | 67 | |
| 68 | |||
| 69 | |||
| 70 | |||
| 71 | |||
![]() |
1.1 | 72 |
